Raspberry, Respeaker et connecteurs grove

Raspberry, Respeaker et connecteurs grove
0

#1

Bonjour,

j’ai installé un raspberry Zero W avec un Respeaker 2-mic.
Le montage fonctionne en tant que satellite pour Snips.

Je voudrais utiliser les connecteur grove pour brancher :

Naïvement je voyais ça un peu plug and play. Comme forcément ça n’a pas marché du premier coup… j’ai dû me plonger un peu plus dans la doc (que j’avais un peu ignorée).

Et me voilà donc avec plein de questions :

  • Grove, en fait c’est juste un type de connecteur qui peut faire passer plein de protocoles différents ?
  • C’est plutôt I2C que j’aurais dû lire, et j’ai l’impression qu’il n’y a qu’un branchement I2C ?
  • Les GPIOs du Raspberry sont en 3.3V… c’est compatible avec ces modules en 5V ?

Si vous avez déjà fait ce type de montage, je veux bien un peu d’aide.
Mon but : changer la carte mère de mon Karotz pour en faire un satellite Snips :slight_smile:


#2

J’ai joué avec des modules grove mais depuis un pi et RaspiO’Mix.

Peut être que @framboise314, @fairesoimeme ou @guillaumelory peuvent te filer un coup de main.


#3

Bon en regardant d’un peu plus près, j’ai l’impression qu’il me faut l’extension Grove pour le Pi Zero :
http://wiki.seeedstudio.com/Grove_Base_Hat_for_Raspberry_Pi_Zero/

  • Est-ce que je peux brancher un Respeaker 2-mic par dessus ? Il n’y a pas des conflits sur des pins en commun ?
  • Le hat est en 3.3V, et j’ai peur que le Motor Driver en 5V ne soit en fait pas compatible.

#4

Finalement, j’ai commandé un GrovePi Zero, qui a du 5V sur les connecteurs grove (https://github.com/DexterInd/GrovePi/tree/master/Hardware).

En regardant les pins je pensais qu’il n’y avait pas de recouvrement avec le Respeaker 2-mic, mais quand j’active les LEDs, ça fait planter la lecture de la mesure de qualité de l’air.

Sinon, pour l’instant semblent fonctionner :

  • Snips
  • Mesure de la qualité de l’air
  • Contrôle des moteurs des oreilles (pas encore branché)