GreeniQ

GreeniQ
0

#164

Ca a l’air hyper clair! Je pense que c’est la version anglaise traduite très clairement en allemand car elle a l’air absolument similaire.
Je la teste ce w-e (la SD neuve est prête!) et si ça marche j’essaie de vous faire une version française dans le même style.
Pour le problème de la sécurité ampérage c’est sûr qu’il faudra bien faire attention de ne pas allumer 2 vannes à la fois.
Pour le moment c’est une solution, en attendant mieux!
En tout cas Abies a l’air au top et bien motivé. Merci!!!


#165

Bonsoir, je suis l’heureux possesseur d’un Gen3 acheté l’été dernier (2018).
J’ai passé le week end à flipper et faire des tests en mode direct avant et après le 1er avril, via hotspot et wifi …
Le résultat : en mode hotspot, la programmation fonctionne (mais je ne sais pas si cela prend en compte la météo) aussi bien sur les vannes que sur l’éclairage (heureusement car je m’en sers pour piloter ma filtration de piscine !!!)
Par contre, les vannes ne déclenchent pas en commande manuel immédiat
En mode wifi, ca ne marche pas bien du tout (pas de déclenchement manuel ou programmé)

A noter que j’ai rebooté le Gen3 au moins 10 fois sur ces 3 jours, j’ai fait plein de fois aussi la synchro horloge ==> le Gen3 perd des minutes à chaque reboot mais bon pas trop grave …

Ma question dans l’interface direct : est-il nécessaire de faire “submit all” pour que le Gen3 prenne en comte les modifs … je n’ai pas réussi à le déterminer (manque de patience et donc appui systématique sur ce bouton après modif de programme)

Attention : j’ai l’impression que les programmations existantes ne fonctionnent que si on les modifie

Enfin : on retrouve bien les noms des zones et les paramétrages (jours pairs, pourcentages, etc …)

En espérant que cela aide…
Et en espérant que quelqu’un trouvera un moyen de refaire fonctionner

Autres question : est-il possible de mettre un relais GreenIQ sur une sortie arrosage 24V AC d’un autre programmateur d’arrosage : je n’arrive pas à trouver la réponse sur le net ?

Merci à tous


#166

Petit teaser :

Vous allez me dire, sur le Gen2 , on a la même chose. Sauf qu’il n’y a que 8 zones !

J’ai réussi une fois à enclencher les électrovannes, je l’ai vu dans les traces :

En bon français, ça veut dire que ça enclenche l’électrovanne 3 et la master valve.

Du coup, j’ai débranché la SD card et suis allé la monter dans le GreenIQ dans le fond du jardin. Et là, bam, marche plus :blush:

Sauf que c’est maintenant une certitude, il y a un problème de date, si on regarde bien la trace par rapport à la précédente, il y a un décalage de 2 heures. Donc une fois ce problème compris, ça devrait marcher :slight_smile: (mode confiant inside)


(cette fois-ci, j’ai demandé 2 zones)

Et comme par hasard, le temps de taper ce post, les électrovannes se sont enclenchées et… l’heure est cette fois-ci bonne :


#167

Pour résumer, soit on utilise SprinklersPi, soit on peut faire refonctionner le Gen2 avec l’interface GreenIQ mais il y a encore du boulot :

  • la boucle du programme est censée faire une minute mais c’est largement plus - du coup, on perd plusieurs minutes après une demande (je suppose que les utilisateurs Gen3 le constatent également)
  • comprendre / corriger ce problème de date de façon à ce que ça marche à chaque fois
  • rafraîchir la barre de progression dans l’application Web (ça reste à 0 %…)
  • j’ai commencé à regarder, le piloter par mqtt ne devrait pas être sorcier (en fait, il le faisait déjà avec un mqtt sécurisé hébergé par GreenIQ)
  • je ne veux pas vendre la peau de l’ours avant de l’avoir tué mais voir comment en faire bénéficier les autres Gen2 (j’ai quelques idées là-dessus, mais chaque chose en son temps)

#168

Et pour les possesseur de Gen3, il y a peut-être un moyen également, cf. une image venant d’un autre forum :

Je dirais une distribution Debian et la bibliothèque Python ablib pour piloter les électrovannes.


#169

Comment tu as fait pour virer les zones qui ne servent à rien sur le gen2 ?
Moi j’ai 16 zones et 2 éclairages alors que j’ai un gen2. En plus il met des programmes dans des zones que je n’ai pas et quand je les supprime ça revient…


#170

Je suis en train de corriger leur application pour la faire fonctionner avec un Gen2 (pour les 8 zones, il faut soit corriger leur script PHP pour avoir par défaut 8 zones, soit créer un fichier port_template.json correct).
Ce matin, j’ai redémarré le GreenIQ, lancé un arrosage et ça a démarré dans les 10 minutes (le temps qu’il prenne la “bonne” heure). Ceux qui arrivent à s’identifier avec le Gen3, je suppose que ça expliquerait pourquoi des fois ça marche, des fois ça marche pas. En fait, le temps “dérive” car le GreenIQ est trop lent de part ses multiples accès au cloud.

Quelqu’un avec un Gen3 peut confirmer ? (et plus on le laisse allumé longtemps, moins bien il marche du fait du décalage de temps)
Comme manipulation, essayer :

  • redémarrage GreenIQ
  • dans les 10 minutes qui suivent, lancer une programmation du genre 30 minutes
  • (quand ça enclenche, vous coupez quand vous voulez)
  • ressayer la même chose plus tard, logiquement, au bout de quelques heures, ça ne devrait pluls fonctionner

#171

Ok je testerais demain la technique du redémarrage et programme manuel durée 30min, là il pleut toute la journée.


#172

Si tu es Gen2, pour l’instant (sans correction de leur appli), ça ne devrait pas marcher du tout (ou alors, gros coup de bol !) Quand j’aurai résolu les points évoqués ci-dessus, si ça vous intéresse, j’essaierai de vous proposer un patch (pour “non informaticien”).
La manipulation proposée, c’était pour les Gen3.


#173

Merci pour toutes les infos. Le hub est à la bonne date/heure lorsque je m’y connecte, il a fallu tout de même cliquer sur “Sync device watch” ce matin car j’étais en 2007. Je dois sélectionner le réseau “SmartGardenHub” sinon accès impossible. J’ai programmé plusieurs arrosages aujourd’hui, pour l’instant ça fonctionne en mode programmation, il n’est par contre plus possible de déclencher les électrovannes en mode manuel.
Je n’ai pas les connaissances pour analyser le code…

green


#174

Pour modifier le programme tu sors la SD et tu la mets dans un autre Raspberry ou tu sors le Raspberry du Gen2 ? J’ai sauvegardé le fichier xlsx de ma config avant que le cloud soit arrêter. Est-ce que ça sers à quelques choses maintenant car on ne peut plus l’uploader.


#175

J’ai le choix en fait :

  • jusqu’à présent, j’avais enlevé la carte SD du GreenIQ Gen2 et l’avais mise dans un Raspberry PI du même modèle (coup de chance, j’en avais un depuis plusieurs années que je n’avais pas utilisé). J’ai fait ça pour avoir un écran branché dessus et car j’ai pas envie de démonter le GreenIQ du jardin.
  • depuis hier soir, j’ai remis la carte SD dans le GreenIQ et je vais le faire à distance
    En fait, j’ai fait cette manip plusieurs fois, quand j’ai eu le mode “urgence” qui s’est enclenché, il a fallu restaurer l’archive, je n’ai pas eu d’autres choix que d’enlever la carte SD.

#176

C’est à priori le même code qui fonctionne sur le Gen3 - il y a quelques différences mais qui sont dues aux écarts de configuration matérielle :

  • le nombre de voies (ce qui met le Gen2 en l’air),
  • l’accès aux entrées / sorties du GreenIQ (on a pour le Gen2 un Raspberry Pi, pour le Gen3 un Ariella GC25 et donc 2 API Python différentes pour les GPIO)
    Et également il semblerait le code de l’application Web vu la différence d’authentification entre les 2.
    Avec un accès possibe à la SD (ou son contenu), ça serait rapide à confirmer.

#177

si tu veux je peut t’envoyer la SD de mon Gen3


#178

Coucou!
Je suis en train de me battre avec mon GreenIQ (le 2).
L’appication Android plante à un moment donné. J’ai réussi à prendre le relai avec mon mac via l’adresse IP, après avoir redémarré le hub 10 fois pour qu’il veuillent bien stabiliser son réseau hotspot.
Après toutes les manips je suis arrivé comme vous au Green IQ direct mais en hotspot seulement. En wifi ça ne marche pas du tout.
Après comme vous, un paquets de zones, il manque la 7 et la 14, et impossible d’avoir la moindre goutte d’eau qui sort.
J’hésite à faire joujou avec la carte SD pour mettre Sprinkler_Pi ou attendre une autre solution. Je ne sais pas lire les codes alors je ne peux pas vous aider!!!


#179

J’ai un Gen2 donc je veux rien du tout :wink: Sans m’engager, pourquoi pas, mais déjà finir le Gen 2 :wink:

Dans tous les cas, un conseil, sauvegarde ta SD si jamais tu n’en utilises pas une autre.


#180

Merci! beaucoup!
J’en ai mis une autre et celle du GreenIQ est ben au chaud dans sa boîte avec la carte qui contient aussi les codes…


#181

Abies je désespère…
J’ai tout installé via le terminal comme indiqué sur la procédure avec la nouvelle carte SD etc…
Tout a l’air nickel mais je n’arrive pas à accéder au panneau de configuration sprinkler.
Dans la barre du navigateur je tape raspberry:8080 mais rien. Le nom de ma machine est bien raspberry. Les ports je vois pas ce qui ne marche pas… any help?


#182

Je comprend tout à fait lol moi il est reparti jeudi chez le revendeur car il était encore sous garantie donc je verrais bien ce que ça donne.


#183

C’est bon j’ai enfin réussi avec la solution Sprinkler_pi. Je viens de faire un test manuel réussi: ça arrose. Il me reste à faire connaissance avec cette nouvelle interface et surtout comprendre comment ça fonctionne à distance.
J’ai un GreenIQ 2 et je suis sur Mac.
Je vous tiens au jus!