GreeniQ

GreeniQ
0

#102

Oui j avais vu cette vente mais il n est pas possible de choisir le format du transformateur (110 v ou 220v)


#103

Bonjour!
A priori sur la photo c’est bien le transfo format européen en 220V.


#104

Bonjour à tous,
Je suis consterné par cet arrêt soudain où tout le monde est lésé.
Tout d’abord est-ce-que certains, qui ont un arroseur depuis moins d’un an, peuvent se faire rembourser? Ce n’est pas mon cas, juste pour savoir.

D’autre part, y a-t-il parmi vous des utilisateurs du GCI 100 de Stihl, qui semble lui aussi être arrêté?

Ne pensez-vous pas que si Stihl a racheté GreenIQ et arrêté son GCI 100, c’est pour lancer quelque chose dans les semaines à venir?

De mon côté, c’est le GreenIQ vert, sur mac et Android. Je vais voir ce w-e ce qu’on peut en tirer…
Certains d’entre vous ont-ils réussi à le faire marcher avec une station météo perso depuis la coupure?

Au plaisir de vous lire!


#105

Déjà, bien que le GreenIQ Gen2 fasse régulièrement des appels à https://hub.greeniq.co/php/api/v2/hub/get_release_file.php?direct=emergency, ce n’est pas à l’origine du problème, donc mon précédent message est inutile.

Une mauvaise nouvelle pour commencer : à “bidouiller” mon GreenIQ, celui-ci a vu une corruption et s’est donc réinitialisé avec une configuration d’urgence (qui n’a rien à voir avec la dernière que j’avais), avant de redémarrer tout seul.
Donc c’est pas prêt de marcher maintenant :smiley: (le smiley, c’est car je suis content d’avoir fait une sauvegarde de la carte SD)

2019-04-02 06:42:48,591 - GreenIQ Initialization and Software Update Utility
2019-04-02 06:42:48,596 - --------------------------------------------------
2019-04-02 06:42:48,602 - Setting up GPIO pins - done.
2019-04-02 06:42:49,776 - Checking internet connection. Trial number #1.
2019-04-02 06:45:12,241 - Checking internet connection. Trial number #2.
2019-04-02 06:47:34,638 - Checking internet connection. Trial number #3.
2019-04-02 06:49:57,041 - Checking internet connection. Trial number #4.
2019-04-02 06:52:19,441 - Checking internet connection. Trial number #5.
2019-04-02 06:54:41,841 - No connection to cloud. Exiting initialization process
2019-04-02 06:57:47,857 - Starting release integrity verification
2019-04-02 06:57:47,867 - release_deployer.json based integrity check
2019-04-02 06:57:47,895 - Expected signature 1c94eb03d9ea8ef6073aef5b3a083a47 actual signature 1c94eb03d9ea8ef6073aef5b3a083a47
2019-04-02 06:57:47,906 - Emergency code validated code integrity. Exiting script.
2019-04-02 07:13:35,274 - Identity on card XXXXXX

Une bonne nouvelle : avec cette configuration d’urgence, j’arrive (en mode geek) à enclencher les électrovannes du GreenIQ.
Exemple avec la vanne n°3 (turbines chez moi donc plus facile pour voir à distance si ça enclenche) :slightly_smiling_face:

Exemple avec le script testGPIO.py :

# ****************************************************************************************
#
# Debug Test
#
# ****************************************************************************************
import greeniq_defs as GD

import time

from hub_model_handler import HardwareHandler

model_utilities = HardwareHandler.getModelUtilities()

# ************************************************************************
# Init GPIO
# =========
try:
    # MAX_PORTS = 8 in model B, 19 in model C
    MAX_PORTS = model_utilities.get_max_ports()

    # For model B:
    # gpio_map  = [7, 11, 12, 13, 15, 16, 18, 22, 26]
    # high_is   = '1'
    gpio_map, high_is = model_utilities.init_gpio()

except Exception,e:
    print("Error in initialization process: ", e)


# ******************************************************************************
# Test valve 3
# ==============
def test_valve_3():
    GD.set_gpio(MAX_PORTS, gpio_map, '00100010', high_is)
    time.sleep(30)
    GD.set_gpio(MAX_PORTS, gpio_map, '00000000', high_is)
    return True

En le lançant, j’ai bien l’électrovanne de la voie 3 qui s’enclenche et se coupe 30 secondes après :

root@sghXXXXX:/home/pi/greeniq/Code# python -c “import testGPIO; print testGPIO.test_valve_3()”
INFO:main:set_gpio: 1: [0], 2: [0], 3: [0], 4: [52], 5: [1], max allowed: [210]
INFO:main:set_gpio: 1: [0], 2: [0], 3: [0], 4: [74], 5: [1], max allowed: [210]
True

Concrètement, maintenant que je pense avoir compris les grandes lignes :

  • je restaure ma sauvegarde de la carte SD
  • j’essaie de voir pourquoi l’application WEB ne “cause” pas avec l’API

#106

Bon et bien moi qui suit en Gen2, Bbox et connexion ethernet je suis arrivé à me connecter avec l’adresse ip trouvé en direct par contre malgré le fait de rentré mes identifiants de connexion de la bbox mon hub reste en statut offline, donc je peux bien faire plein de sélection via l’interface en direct mais le raspberry ne déclenche aucune électrovanne, je n’arrive pas a lui envoyé de commande, comment faire pour le basculer en online ? Mon champs de compétence se réduit :frowning: mais je veux bien apprendre si quelqu’un maîtrise ?!?


#107

On a le même problème :slight_smile:


#108

Je reformule pour être sûr de comprendre - tu as bien accèsà l’application Web, comme on voit sur l’image de gregomino :

Mais quand tu enclenches, ça ne fait rien ? Si c’est bien le cas, tu as le même problème avec un Gen2 que manu92 et moi (Sebastien et Gregomino sont en Gen3, les autres, je ne sais pas)

En tout cas, à ceux qui envisagent de laisser tomber GreenIQ, il y a des solutions, certes pour l’instant très informatiques, qui se profilent :


#109

C’est exactement ça, il n y a l’air d’avoir aucune connexion entre le Hub et le serveur, le hotspot fonctionne mais aucune info ne lui parvient. Et le truc super bizarre c’est que j’accède via deux adresses ip différentes celle de ma box 192.168.1.76 et celle de greeniq 10.0.0.1 mais aucune fonctionnent.


#110

Hello,
J’ai peut être une piste qui expliquerait pourquoi la connexion n’est pas possible comme décrit dans la procédure envoyée par Green IQ.
Cela devait marcher apres le premier Avril.
Or on est le 2 et ma console est toujours à la date du 31 mars 18h45…

image


#111

donc le bouton sync Device watch ne fonctionne pas !!! il reste donsc plus qu’attendre deux heures ? ( je parle pour moi mon horloge est a 22 h) ou elle tourne en boucle sur la date du 31 :frowning:


#112

Sauf que je suis bloqué sur 18h45 et ca bouge pas…
Je tenterai un redémarrage complet ce soir pour voir.


#113

Bon et bien moi, j ai commandé le RainMachine Pro8.
Une fois reçu et installé, je reviendrai pour vous dire ce que cela donne


#114

Je suis à deux doigts de craquer, ce qui me réserve c’est qu’il n’est pas fait pour être installé en extérieur :frowning: et le rain bird j’ai peur de son wifi avec son d’ongle :frowning:


#115

Il faut l installer dans une grosse boîte de dérivation étanche et là, plus de problème


#116

Bonjour à tous, est-ce que ceux qui ont la GEN 2 vous avez comme moi 16 zones d’affichés au lieu de 6 ?
On dirait qu’ils ont bricolé le firmware GreenIQ direct pour la GEN 3 et ceux qui sont en GEN 2 l’ont dans le baba…
Et chez moi aussi la date est bloquée


#117

Ce que je me disais aussi


#119

J’avais bon espoir hier puisque j’ai réussi à piloter mes électrovannes assez facilement. Mais aujourd’hui pour une raison que j’ignore la station reste “offline” pourtant celle-ci est bien reconnue par la bbox bouygue :frowning: L’envie de faire un petit lancer du disque m’a traversé l’esprit…


#120


#121

L’horloge est donc bien figée et le hub offline

Et pourtant mon boîtier est connecté en ethernet avec une adresse IP.


#122

Ok pareil ici jusqu’à ce matin depuis je n’ai même plus accès à cette page