GreeniQ

GreeniQ
0

#82

il y a des infos par ici


ou la
https://opensprinkler.com/forums/topic/gpio-modification/

j’ai commencé a faire un peu de reverse depuis l’api locale, il y a des choses a faire.


#83

Oui je pense qu’il va en sortir un truc prochainement!


#84

je suis toujours à la recherche de mes identifiant mdr!! J’ai certainement perdu cette putain de carte.
Je sait déjà que le mot de passe est sur 8 chiffres, et il me manque le format de l’ID si l’id était identique a tous je pourrait peut être le craquer grâce à l’application Brutus.


#85

Bonsoir
Mon identifiant est composé de 3 lettres majuscules suivies de 3 chiffres.


#86

merci! je pense que j’ai pas fini de galérer lol


#87

GreenIQ : Gen2 6 zones WiFi
Connection utilisée : filaire (RJ45), le WiFI ne passe pas dans le jardin

Procédure :

  • comme supposé hier, une fois branché, le GreenIQ prend son bail DHCP mais ne se déconnecte pas - en me loggant sur http://192.168.1.7 (adresse IP fournie par le serveur DHCP de la Freebox), j’arrive bien sur l’appli WEB, sans aucun login/mdp demandé - l’IHM indique que les électrovannes sont ouvertes, mais non, rien qui sort.
    Dans cette configuration, les LED Power et Network sont allumées vertes
  • en suivant la procédure (2e partie), Ethernet débranché, en me connectant en hotspot, en allant sur http://10.0.0.1, je tombe sur la même appli WEB. Aucun login/mdp lancé, mais bien que l’IHM suggère que les électrovannes sont ouvertes quand je le demande, rien ne se passe.
    Dans cette configuration, seule la LED Power est allumée
  • en essayant l’option “step 1”, vu que j’ai le bon firmware, l’application Android plante quand je passe en mode “hotspot” (les IHM Android sont différentes des copies d’écran de la procédure envoyée par GreenIQ)

J’ai essayé de voir les sorties GPIO avec les câbles de connexion, mais c’est un PCB 4 couches donc pas immédiat de faire la correspondance entre le connecteur Raspberry et les câbles des électrovannes. Merci pour le lien ci-dessus qui donne une 1re idée des correspondances !

Le SSH est activé sur le Raspberry, mais le compte par défaut pi/raspberry n’est pas actif :confused:


#88

Il t’a demandé des identifiants ? Sur l’application WEB, j’ai rien qui est demandé !


#89

Tu modifies comment l’API locale ? Carte SD montée sous Linux (voire Windows) ou tu as accès en SSH au GreenIQ ?


#90

Bonsoir

Je confirme. Exactement la même configuration et le même constat. Comme j’ai le wifi j’ai essayé aussi sur l’adresse wifi mais ca ne change rien.
J’ai rééssayé ce soir 1er avril et le constat est le même à un écarte prêt : la semaine dernière la led Network s’allumait au départ puis s’éteignait. Et depuis aujourd’hui, elle reste allumée en permanence.


#91

Bonsoir gregomino. Peux tu préciser ta config STP ? Gen 2 ou Gen 3 ? Nombre de voies STP ?

Merci

Emmanuel


#92

oui sur l’appli web et même l’appli android en connexion directe


#93

perso je suis en Gen 3


#94

Bonsoir, je possède la Gen3 / 8 voies achetée au mois d’Octobre dernier. Connection uniquement en wifi donc.
Je n’avais pas de carte avec identifiants dans la boîte. Je me suis toujours connecté avec mon adresse mail et mon mot de passe. J’'ai une box bouygue et mac OSX/iphone.
Je me suis connecté à l’interface de la box bouygues pour trouver l’adresse de la station Greeniq. Chez moi c’est 192.168.1.25
J’ai rentré cette adresse sur le navigateur safari sur iphone et ça a marché… pas du premier coup. J’ai dû rebooter plusieurs fois la station ainsi que la box. Puis la station Greeniq est apparu dans la liste des réseaux wifi disponibles. J’ai ensuite suivi la procédure. Je ne crois pas avoir rentré mes identifiants, la reconnaissance du réseau et de la station s’est effectuée automatiquement. Il a suffit de sélectionner le réseau wifi et la clé wep.
J’espère que ça pourra aider !!


#95

Ha ça me rassure cette histoire de carte! Sauf que de mon coté mon id et pw de mon compte en ligne passe pas du tout.


#96

Tu as vérifié que ça enclenche bien les électrovannes ? De ta copie d’écran, on voit bien le on/off, j’ai pareil, mais ça ne commande pas les électrovannes.


#97

Oui ça commande mes électrovannes en manuel je peux les déclencher/stopper, régler la durée et les programmer. Pour la programmation justement j’attends de voir demain matin si elle a fonctionné.
Bon pour être honnête ça me semble très précaire et provisoire comme utilsation…


#98

Station offline ce soir plus rien n’'est accessible donc c’est mal parti…


#99

Non, il n’y a aucun écart, j’avais également la lumière network qui s’allumait avant de s’éteindre quelques minutes après.

[Message édité, ce n’était pas ça]


#100

Non pas d’accès Ssh, juste analyse des requêtes http générées par l’interface web.

Je testerai demain d’installer armbian sur une nouvelle carte.


#101

Hello, J’avais trouvé cela: https://shop.rainmachine.eu